CentOS’da Composer Yükleme Hatası

Laravel kurulumu yapmak için CentOS’a Composer kurmam gerekiyordu. Composer kurulumu için komutu yazdığımda “The suhosin.executor.include.whitelist setting is incorrect.” gibi bir hata verdi.

Çözüm için php.ini dosyasına bir satır ekledim. Sırayla nasıl yaptığımı anlatayım.

Nano ile php.ini dosyasını açtım:

nano /etc/php.ini

Açtığım dosyanın en altındaki “; END;” satırından öncesine aşağıdaki kodu yazdım:

suhosin.executor.include.whitelist = phar

CTRL + X deyip belgeyi kapattım ve kaydettim. Daha sonra Apache’yi de yeniden başlatırsak tamam olacak:

sbin/service httpd restart

Sonrasında Composer’ı kurabiliriz:

curl  -k -sS https://getcomposer.org/installer | php

Kolay gelsin.